Jump to content

Warning: "AdBlue - system with failures"


antonio_ok
 Share

Recommended Posts

I have a BMW 520d GT and in the last ~10 kmiles this warning is coming up repeatedly. It disappears disapears after a while and back again. Nothing really happed.. so far, but would like to get rid of it. Any experience on this? Thank you.

Link to comment
Share on other sites


A hire van I had refused to start after the addblue ran out. I would buy some and top it up to make sure it’s full

 it sounds like it is giving you a warning it may be getting low. The sensor may be active intermittently as the liquid is sloshing around. 
 

... stupid invention! Lol

  • Like 1
Link to comment
Share on other sites

No. its not empty. That was my 1st reaction too. Didn't work.

It's not full either... indeed I can to top it up and see what happens...

Also crossed my mind that for any reason it didn't like the last AdBlue liquid I used... it was an universal one, dont see any reason why it could cause these warnings. Should I empty the AdBlue depo and refill it with new one?

Link to comment
Share on other sites

Hi Antonio

Your hand book should give some information, though like oil there must be some leeway for top up/refill while "on the road" it can't always be done at a dealer. Unless BMW have a reset some where that tells the system the tank has been refilled ??

As said I have no Adblue experience so thinking out loud here

Dave

  • Like 1
Link to comment
Share on other sites


  • 2 weeks later...

In the meantime I refilled the ADBlue depo, hoping that it could help stopping the warning.. It didn't stop 😞 The warning in on after driving 40 ou 50 miles. After I turn off and start again, the warning goes away.

This is really a mistery for me, I cant get rid of it.

I am still hoping that someone went through a similar situation and can help me.

Thank you

  • Like 1
Link to comment
Share on other sites

Morning Antonio

From a little reading it seems the Adblue tank on your car hold 17litres 😲 how much are you putting in?

My money is on a reset being needed again from reading refill turn on the ignition (do not start the car) 30 secs minimum then off and start, or I seem to remember there being a recall for the Adblue systems ??

Then again it may just be my old brain failing and needing a reset?

  • Like 1
Link to comment
Share on other sites

On 4/2/2021 at 8:34 PM, SuzukiBoy2 said:

Hi Richard

Mercedes, and possibly other diesels use AdBlue as well. I know about the Mercedes because my daughter had one which needed a top-up.

I'm fairly sure it's on her latest car as well, a diesel Range Rover Evoque.

Learning, learning, all the time !!

John

Link to comment
Share on other sites

On 4/15/2021 at 8:34 AM, SilverJohn said:

Hi Richard

Mercedes, and possibly other diesels use AdBlue as well. I know about the Mercedes because my daughter had one which needed a top-up.

I'm fairly sure it's on her latest car as well, a diesel Range Rover Evoque.

Learning, learning, all the time !!

John

Hi John,

Yes I (now) know a bit more. Many manufacturers adopted it early. It is now mandatory. BMW adopted it with all 2018 diesel models onwards.

Link to comment
Share on other sites

  • 1 year later...

I have a similar model and a similar issue. The dealer replaced a wire insulation from the sensor that solved it. Apparently the wire had become loose and the insulation had worn through.  

Link to comment
Share on other sites

HI Tim 

i have the same problem my adblue system shows warning three times then the engine admissions light comes on .

I've had tank cleaned ,line checked, injector changed and its still doing it its costing a fortune .Ive been told to look at a wiring loom by the adblue tank as it might be chafing on body work by all accounts the loom is to short . ROY

Link to comment
Share on other sites

On 3/31/2021 at 4:19 PM, antonio_ok said:

I have a BMW 520d GT and in the last ~10 kmiles this warning is coming up repeatedly. It disappears disapears after a while and back again. Nothing really happed.. so far, but would like to get rid of it. Any experience on this? Thank you.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



  • Latest Topics

    1. 0

      X3 2019 roof bars and bike carriers for sale

    2. 1

      High mileage 5 series advice/ help.

    3. 1

      High mileage 5 series advice/ help.

    4. 4

      DBC, FTM & DSC malfunction

  • Recent Achievements

    • GB1963 earned a badge
      Week One Done
    • Russco earned a badge
      Conversation Starter
    • Mike_77422 earned a badge
      Conversation Starter
    • AaG27 earned a badge
      Conversation Starter
    • Jeffry Baron earned a badge
      Week One Done

×
×
  • Create New...

Forums


News


Membership