Jump to content

Z3 fuel


Recommended Posts

Hi guys today I picked up my z3 2.2 2001. Driving home 19 miles an a normal 40mph rd the fuel gauge went down over quarter of a tank also I wasn't that impressed with the power. Its my 1st z3 . I had a D 1986 318i years ago and was a lot quicker and fuel wasn't bad. Do you think there's something wrong??.

  • Like 1
Link to comment
Share on other sites


Morning Darren

Welcome to the Forum

The 2.2 engine always had a reputation for good fuel economy somewhere in the high 20's around town so I suspect you have an issue (or 2)

I would start with the obvious such as, Tyres are the inflated correctly, Brakes nothing binding ? When was the car last serviced? 

Dave

  • Like 1
Link to comment
Share on other sites

26 minutes ago, Greydog said:

Morning Darren

Welcome to the Forum

The 2.2 engine always had a reputation for good fuel economy somewhere in the high 20's around town so I suspect you have an issue (or 2)

I would start with the obvious such as, Tyres are the inflated correctly, Brakes nothing binding ? When was the car last serviced? 

Dave

Thanks dave tyres are all OK no brakes binding. I am booking it in today for service . Il see how it goes. Il let you know . Thankyou 

Link to comment
Share on other sites

Hi Darren.....welcome to the Club

I agree with Dave on the above. Have had calipers seize on me and has reduced the power significantly if the brakes are dragging.

The fuel gauge on the Z3's are at best an indication of what you have in the tank but this can change by the minute....wouldn't ever rely on the accuracy of that particular gauge

Link to comment
Share on other sites

Hi guys just a up date on my z3. I filled it right up with fuel to see how it went. Its been fine and doing the mileage that it should. Relized that when I picked the car up originally it was parked on a steep driveway and I think it just took a while for the gauge to move . So thinking I brought it with half a tank of fuel it was obviously nearly on the red 😆.  Thanks for your replies anyway.

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



  • Latest Topics

    1. 15

      Splutters when start from cold.

    2. 15

      Splutters when start from cold.

    3. 2

      R61 JCW Mystery no code fault

    4. 15

      Splutters when start from cold.

    5. 4

      Cylinder 1 misfire

  • Recent Achievements

    • Joseph80 earned a badge
      One Month Later
    • SkipG earned a badge
      Conversation Starter
    • SkipG earned a badge
      One Month Later
    • SkipG earned a badge
      One Year In
    • LesBimmerLBK earned a badge
      One Year In

×
×
  • Create New...

Forums


News


Membership