marleymilo

Warning Lights on start up

Recommended Posts

Hi all, I keep getting warning lights as soon as start up car, saying rear brake light failure or rear fog light failure, but having checked them from the outside they illuminate fine, is there some sensor somewhere or anything else that could be causing these errors?

Share this post


Link to post
Share on other sites
 

Hi Ian

X5's love "bonging you" checks your heart rate and how fat your wallrt is feeling.

Lights self check (along with a lot of other stuff) when you turn on the ignition, the rear light cluster's can suffer from corrosion the low voltage used in the self test looses continuity so thinks there is a lamp failure. I would check and clean  the lamp holders in the rear swap lamps around see how it goes. Good can of contact cleaner and some wet and dry then a dab of Vaseline has worked for me.

Dave 

 

 

Share this post


Link to post
Share on other sites

Thanks, I have replaced the bulb holders in both clusters, but think I will have to give them all a good clean.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...