Jump to content

Gear maybe engaged without breaking


Recommended Posts

 Dear members,

Has anyone experienced the following.   I have BMW 650I 2007.  I live in Santiago Chile.   2 weeks ago my mechanic replaced solenoid 4 and 5 on my automatic transmission using the 2 year old transmission fluid to drain and refill.  2 days after I started to experience the following.  After I drive my car for a while and I switch off the car for around 2-3 minutes when I try to turn it on again I receive this sign in the dashboard: "Gear maybe engaged without breaking". When this sign comes on the start/stop button goes dead and the gear shifter gets stuck in park. After about 20-30 minutes the car gets back to normal. I complained this issue to the mechanic and he told that the Mechatronic control unit needs to be replaced because it's dying.  

Does anyone experienced this problem?.  It's driving me crazy because before the mechanic changed the 2 solenoid I didn't have this problem at all.   Please help.

Many thanks. 20240615_174338.thumb.jpg.a54c0a41ce934b0da3ab7a698f536c16.jpg20240615_174333.thumb.jpg.0b9f04a65c24d6c3b81bb4bba0c1ff6b.jpg

Link to comment
Share on other sites

Morning Taysir

Welcome to the Forum

As your "mechanic" had drained the transmission and removed the sump and filter to change solenoids he then put back using old contaminated Fluid and possibly/probably a used contaminated filter ????? it just doesn't make sense.

Find another transmission specialist (preferably ZF) and get the trans diagnosed and the fluid flushed and changed

Good Luck

Dave

Link to comment
Share on other sites

4 hours ago, Greydog said:

Morning Taysir

Welcome to the Forum

As your "mechanic" had drained the transmission and removed the sump and filter to change solenoids he then put back using old contaminated Fluid and possibly/probably a used contaminated filter ????? it just doesn't make sense.

Find another transmission specialist (preferably ZF) and get the trans diagnosed and the fluid flushed and changed

Good Luck

Dave

Good morning Dave.  Thanks for your prompt reply. 

I forgot to mention that indeed my mechanic has replaced the old transmission fluid pan with a new one that has the filter incorporated but never changed the fluid.  Is that could be the problem??.  I took my car to another transmission specialist and he made a thorough diagnosis and the result is NO codes of transmission errors. 

Link to comment
Share on other sites

Hi Taysir

So after you diagnostic scan and no fault is your Trans performing as it should?

I have never heard of a Trans Specialist re-using Fluid.  It is like like draining old oil from the engine changing the filter and putting the old oil back ??? You just wouldn't do it. As said the old fluid will contain all sorts of contaminants which he just put back??  

Dave

 

Link to comment
Share on other sites

Good morning Dave,

After the no fault diagnostic scan my car still receiving randomly the sign Gear maybe engaged without breaking and the shifter gets locked in P.  "Stard/Stop button is dead.  I have to wait about half an hour for the car to cool down then it will start and everything back to normal. 

Now the Trans specialist is suggesting to change the TCM unit and to replace the old fluid and filter with new one a job that will cost around $1000.00 Dollars.  I am not sure if this will fix the problem. I already paid $900.00 Dollares to change the 2 solenoids and filter plus labor.

Link to comment
Share on other sites

Hi Taysir

As this guy has already drained the fluid is he even sure that the levels are correct ??? I doubt they are as you seem to have an over heating trans (having to wait for it to cool down) Sadly stay away from there. A decent Trans Specialist will tell you straight away by diagnostics if the TCM has a fault, here in the UK a ZF 6 speed auto service kit Fluid Filter and Sump costs around £250 so if the work were carried out by a Trans Specialist I would expect a cost of around £500 maybe £600 in USD probably $650 to $750 

Check for any leaks check the Trans cooler is working OK your trans should be operating around 90c 190f if it is above that then something is wrong. How is engine temp? in the middle of the gauge ?

Dave

Link to comment
Share on other sites

Hi Dave

Sorry for the delay in replying.  We been having a very bad weather and lots of heavy flooding which didn't enable me doing anything with my car.

I already stayed away from my mechanic and replacing the TCM and the fluid was diagnosed by another trans specialist despite no codes has ever appeared in his famous scan. They diagnosed replacing the TCM without even checking the trans fluid level. 

On Tuesday I'll take my car to another mechanic only to check the fluid level before I finally hit the BMW Dealership.

The strange thing Dave is when I drive around the city nothing happened but when I go on the highway for a good while then I shut off the engine for no more than 5 minutes and come back to start it this is when the message appears in orange color then in red and when that happens the button start/stop goes dead and the shift lever gets stuck in P.

By the way, back in 80th I lived in Churchdown near Gloucester for a couple of years with my British girlfriend until my mom got very sick and had to return to Chile.  I still miss very much the good old pubs in Gloucester. 

 

 

Link to comment
Share on other sites

Morning Taysir

The more information we get the more it seems like either low fluid or overheating (or both) 

Hope you get a sensible fix

Dave

Link to comment
Share on other sites

Latest Deals

BMW Official Store for genuine BMW parts & accessories

Disclaimer: As the club is an eBay Partner, The club may be compensated if you make a purchase via eBay links

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





  • Latest Topics

    1. 5

      BMW 530d Rear Diff replacement issues!

    2. 2

      325i aux water pump

    3. 5

      BMW 530d Rear Diff replacement issues!

    4. 2

      325i aux water pump

    5. 2

      325i aux water pump

  • Recent Achievements

    • Bluebeard earned a badge
      One Month Later
    • Jonesg earned a badge
      First Post
    • Jonesg earned a badge
      Conversation Starter
    • OSWALD earned a badge
      First Post
    • Droffilc earned a badge
      First Post

×
×
  • Create New...

Forums


News


Membership