Jump to content

E66 76Li - help needed with errors


4by4
 Share

Recommended Posts

Hi all

New member here. I've had various 7 series over the years. My current ride is an E66 760Li which I've had for just over a year. It has got a few issues as shown below. When I bought the car, interior was very dirty. I had the complete interior swapped with individual interior of exact same spec, albeit in a different colour.

Questions: Do seats, ask unit, steering angle sensor etc need programming after replacement?

Issue 1 - Engine misfire (new plugs, new coil packs, fuel pump replaced - injector teflon seals and O rings on order now as next step)

Issue 2 - iDrive / logic 7 doesnt work - It wasn't working when I bought the car. I had the entire system replaced including ASK unit, dash Cd Changer, logic 7 amp, DVD changer, Satnav unit. It started to work. Car was parked up over winter and now it has stopped working again.

Issue 3 - Airbag light on
Issue 4 - Seat belt warning light on
Issue 5 - Yellow triangle / Drive control error

Errors as following:

1- SIM/SGM 93F4 - Airbag?
2- SZL 9501 - Steering Angle? (error stays despite replacement squib)
3- SSH 9A79 - belt buckle switch - rear left?
4- DME/DDE 29E3 - C1 / C2 misfire?
5- DSC 5EF4 - Steering angle? (error stays despite replacement squib)
6- EMF 6040 - Parking brake?
7- EHC 5F8F - rear right height sensor (error stays despite replacement sensor)
8- TMFTH - DC84
9 - TMBTH - DCC4
10 - KOMBI - E110 - instrument cluster
11 - PDC - 9E31-32-39 - Parking sensors
12 - CIDF - A488
13 - KLIMA - 9C56 Fogging
14 - KLIMA - 9C64 AUC

Any E65/66 experts / programmers in or around London who can help? Ideally someone who has some cars for breaking as well so parts can be swapped if needed.

All help would be muchly appreciated. Happy to pay to get these issues sorted by someone who has experience , knowledge and parts if needed.

Many thanks in advance

Link to comment
Share on other sites

Hi. 
what state is the battery in? 
Charge it fully and then clear and recheck the codes. 
my x5 starts throwing up wired and wonderful things like angle sensors and the like when the battery is a bit low. 
 

Link to comment
Share on other sites

14 hours ago, X5smw said:

Hi. 
what state is the battery in? 
Charge it fully and then clear and recheck the codes. 
my x5 starts throwing up wired and wonderful things like angle sensors and the like when the battery is a bit low. 
 

Brand new Bosch AGM battery, registered as well using INPA 

Link to comment
Share on other sites

Morning Mobeen

Battery may be new but is it fully charged ? Is the alternator output correct and charging the battery 

You have replaced a large number of parts so start there

1. Were they correct for your model (use a Vin decoder to get the original build sheet) and www.realoem.com for part numbers

2. Were they coded in to the cars system or just swapped?

3. If the replaced items are correct and coded correctly then check all earth points, BMW are fond of using body earth points with multiple connections. They are also fond of using earth switching so any poor connections can cause havoc.

Remember that some functions need an enabling code from BMW (I know they just don't like us tinkering with "their cars" that they conveniently forget we have paid for)

Good Luck

Dave

 

 

Link to comment
Share on other sites

Thanks for your reply David

 

Donor vehicle was exact same spec as my car. comfort heated seats, logic 7, night vision, rear entertainment, fridge, rear air con vents on roof lining, rear window blinds, soft close.

There has been no coding done, only the parts have been swapped including a replacement steering angle sensor. Do we have a programming expert on here?

Also, audio was working fine when complete logic 7 system was moved from donor car to mine and it worked in my car after swap as well. Car was parked up for winter/rainy months. Started it up 2 weeks ago, installed a brand new Bosch AGM battery which is the correct battery for the car. However, audio system doesn't work anymore. I can't press any icons on the screen using the idrive button.

Link to comment
Share on other sites

Morning Mobeen

Even with BMW's early i-bus system components that communicate with each other or allowed pass through signals to reach others could be swapped. However they didn't always operate as they should or allow their full operation. They needed not programming but registering to the cars chassis to allow full functionality.

I would start by checking all body earth points, BMW love multiple earth points and earth switching so make sure they are good being parked up could have allowed corrosion to start, it wont take much. 

Use www.realoem.com to check if any enabling codes are needed for the audio/nav system. The steering angle sensor normally calibrates itself if the car is driven forward while going lock to lock 

What diagnostic system are you using 

Dave

Link to comment
Share on other sites

Latest Deals

BMW Official Store for genuine BMW parts & accessories

Disclaimer: As the club is an eBay Partner, The club may be compensated if you make a purchase via eBay links

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





  • Latest Topics

    1. 5

      BMW 530d Rear Diff replacement issues!

    2. 2

      325i aux water pump

    3. 5

      BMW 530d Rear Diff replacement issues!

    4. 2

      325i aux water pump

    5. 2

      325i aux water pump

  • Recent Achievements

    • Bluebeard earned a badge
      One Month Later
    • Jonesg earned a badge
      First Post
    • Jonesg earned a badge
      Conversation Starter
    • OSWALD earned a badge
      First Post
    • Droffilc earned a badge
      First Post

×
×
  • Create New...

Forums


News


Membership