Jump to content

Loss of power


DERRYDARRYL
 Share

Recommended Posts

Can some help me with this, just recently replaced a fuel injector and glow plug. Since then the car has been very sluggish, white smoke from exhaust when I put the foot down and there's a pull back in every gear. I've had the DPF AND EGR removed and eco map put in and still no change. I starting to get worried now when I read about it I'm seeing things I don't want to see, anyone any recommendations thanks darryl

Link to comment
Share on other sites


Hi Darryl

Welcome to the Forum

BMW did change injectors so if you have a mix of Old Style and new it will cause issues also when fitting a single injector, it needs coding/adapting to the car if that wasn't done it could be massively over fuelling on that cylinder hence the white smoke. 

If you come across a fussy MOT Inspector EGR and DPF delete will be a very expensive failure.

Dave

 

Link to comment
Share on other sites

5 hours ago, Greydog said:

Hi Darryl

Welcome to the Forum

BMW did change injectors so if you have a mix of Old Style and new it will cause issues also when fitting a single injector, it needs coding/adapting to the car if that wasn't done it could be massively over fuelling on that cylinder hence the white smoke. 

If you come across a fussy MOT Inspector EGR and DPF delete will be a very expensive failure.

Dave

 

Much appreciated dave, is there a way to campare the new type injector to the old type. I've had it coded in also thanks darryl

Link to comment
Share on other sites

Morning Darryl

Check the part numbers, use www.realoem.com put the last 7 digits of your Vin into the search box it will bring up your model then look in the relevant section. All the OEM part numbers are there double click the part number and it will show a list of alternates and any other models they were fitted to. Check against the part number you fitted.

I have never changed single injectors just sets and only diesel, but I have read that around your model year BMW upgraded the injectors which should only be fitted in sets not mixed.

Also check the coding was it recognised? I fitted a replacement inner rear light to a friend's E70. The car still reported bulb failure it took 3 attempts before the car believed we had fixed the fault.

Good Luck

Dave

Link to comment
Share on other sites

Good morning dave much appreciate the feed back,, Al have a look into this today. Also have another problem now, went to take the car a good run last night and now back reverse gear won't stay in position. Mechanic thinks it may be the cable but would you have any other solutions thanks darryl

Link to comment
Share on other sites

Hi Darryl

Have you carried out any work around the Gearshift area? Is the car Auto or Manual? 

Obviously very difficult to diagnose without seeing/feeling the issue and knowing what else has been done.

Dave

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share




×
×
  • Create New...

Forums


News


Membership