Jump to content

Hi guys


Recommended Posts

I have just bought a lovely 2005 X5 e53 3.0d and it's lovely to drive until I get on the motorway and it won't rev past 3800rpm even sat in N it does the same. Surely it can't be a massive issue as it drives so well under that. Has anyone else had an issue like this?

Thanks

Sorry for my first post to be a question

Martin 

Link to comment
Share on other sites


Morning Martin

Welcome to the Forum

Could be the fuel pressure sensor, take the engine acoustic cover off on the passenger side of the engine is the inlet manifold plenum. At the back of the plenum you will see a sensor and plug, unplug it if the engine now runs freely through the revs the sensor is probably your issue. If not then a scan is needed to determine just what it is.

Dave

  • Thanks 1
Link to comment
Share on other sites

  • 4 weeks later...
On 6/25/2022 at 6:52 AM, Greydog said:

Morning Martin

Welcome to the Forum

Could be the fuel pressure sensor, take the engine acoustic cover off on the passenger side of the engine is the inlet manifold plenum. At the back of the plenum you will see a sensor and plug, unplug it if the engine now runs freely through the revs the sensor is probably your issue. If not then a scan is needed to determine just what it is.

Dave

Hi Dave it was the fuel filter believe it or not. It looked like the original one from the factory some 17 years ago 😳

Thanks Martin 

Link to comment
Share on other sites

  • 2 weeks later...

Morning Lusy

Welcome to the Forum

The X6 was designated E71 by BMW and made between 2007 and 2014 engines were from 3.0d through to the M5.0 There was a short rum of Hybrid models made for some markets between 2008 and 2011. In 2013 the F15 model was introduced with a similar engine range (though uprated)

If you need more let us know

Dave

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



  • Latest Topics

    1. 15

      Splutters when start from cold.

    2. 15

      Splutters when start from cold.

    3. 2

      R61 JCW Mystery no code fault

    4. 15

      Splutters when start from cold.

    5. 4

      Cylinder 1 misfire

  • Recent Achievements

    • Joseph80 earned a badge
      One Month Later
    • SkipG earned a badge
      Conversation Starter
    • SkipG earned a badge
      One Month Later
    • SkipG earned a badge
      One Year In
    • LesBimmerLBK earned a badge
      One Year In

×
×
  • Create New...

Forums


News


Membership