Jump to content

MHEV battery issues


DRH56
 Share

Recommended Posts

Hi Folks - new to this forum so please bear with me! I'm not sure that the behaviour of my X3 MHEV is to be expected. Under the BMW CarData Archive I'm getting some very strange readings of the battery %. It goes from 0% to 63% (with an average of 34%) over a 10 day period.

Issues: (as seen on "Energy Flow" Display)

1 Appears to not be holding charge. Display goes from 1> 3 bars and back to 1 within a mile of driving
2 Rarely freewheels, mainly does regeneration braking
3 When freewheeling display mainly shows vehicle not charging with engine "on" rather than "Ready"

Is this "normal" behaviour? In other words - is the MHEV "blurb" just a marketing tool with little real world benefit?!

Link to comment
Share on other sites


Just back from two days at the BMW dealer looking at this. They tell me that it's just a small battery and BMW techs at Head Office say this is normal behaviour. So, I'm guessing that it's really little more than a marketing tool that only has a minor impact on the vehicle's behaviour

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership