Jump to content

Please any help m52tub28


Jacktate98
 Share

Recommended Posts

Can anyone help please I’ve just replaced the thermostat on my 1999 328 m52 engine and it’s seems to not be cooling down this was the thermostat that I took off it has nothing inside is there a reason why?......When I got the car the fan was broke and someone had cut all the wires well I can’t find any anyway. so I put a electric fan on a switch that’s when I noticed the thermostat wasn’t working the car temp would just keep dropping but now I have the new one in it got to 92 I put my fan on and it just kept going up? Any help appreciated 

F44FDF21-1CD7-4A83-971E-0AA83EDD7B81.jpeg

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



  • Latest Topics

    1. 0

      Drive Train

    2. 0

      07 LCI M-Sport front bumper needed 😞

    3. 1

      Bleeding rear shocks 635csi

    4. 1

      I’m an idiot (PLEASE HELP)

  • Recent Achievements

    • CalamityCarls earned a badge
      Conversation Starter
    • Swingy_p went up a rank
      Apprentice
    • Envyous earned a badge
      Conversation Starter
    • Bill Gocke earned a badge
      Conversation Starter
    • scimitargtc earned a badge
      Conversation Starter

×
×
  • Create New...

Forums


News


Membership