AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.

Recommended Posts

louthster    0

Good morning my fellow X3 owners, greetings from an overcast Welwyn, Herts, Uk, I find my old 2007 x3 2.0d Msport is a bit sluggish so I was thinking about getting her remapped but as the car has 162000 miles on her im worried a remap will cause the car to go wrong, ie turbo etc, what are your thoughts, advice etc, also she's hard to start from cold & always needs the accelerator pressing to get her going, from warm its 1st turn of the key, any ideas, finally, I sometimes get a diesely fumes smell in cabin esp sitting in traffic, but the pollen filter looks clean, all ideas & advice greatly appreciated, stay safe out there & TGIF 1f642.png

Share this post


Link to post
Share on other sites
 
Trevor    38

Hi David....welcome to the Forum

Sounds like the glow plugs need replacing to get it starting properly.

You could try a tuning box (DTUK do a good one)

Cheers  Trevor

Share this post


Link to post
Share on other sites
louthster    0

Thanks young fella & that's exactly what I was thinking cos when she's warm she starts no problem at all :)

Share this post


Link to post
Share on other sites
dubbed    0

Welcome! Update us when you got new glow plugs installed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now