Jump to content

Rear wiper noise help


Swingy_p
 Share

Recommended Posts

Evening,

Have just changed the rear wiper blade and now am getting a god awful clicking noise coming from the arm and it doesn't sweep as much of the screen as it did before, what the hell have I done!! 

(Hope the very poor video clip helps)

Regards Paul 

Link to comment
Share on other sites

Can you do a video showing the whole rear window looking from the back of the car. I would guess that the new wiper is the same size as the old one ? 
can you put the wiper back on the window and see if it clears the spoiler near the brake light. I’m guessing the wiper arm has moved on its mount and now hits too far left, which would cause a bang and not sweep as far to the right. 

Link to comment
Share on other sites

7 hours ago, X5smw said:

Can you do a video showing the whole rear window looking from the back of the car. I would guess that the new wiper is the same size as the old one ? 
can you put the wiper back on the window and see if it clears the spoiler near the brake light. I’m guessing the wiper arm has moved on its mount and now hits too far left, which would cause a bang and not sweep as far to the right. 

Morning,

It's not the wiper arm hitting anything as it even makes the noise when the arm is pulled back off the screen.

Will do a better vid later once on my break and hopefully someone can telle what I've done 😞 

Link to comment
Share on other sites

As you can see, it's got nothing to do with the blade coming into contact with anything nor does it do the full sweep of the screen anymore so I've no idea what's happened as just pulled the arm up and swapped out the wiper blade at the weekend 🤷🏻‍♂️

 

Link to comment
Share on other sites

2 hours ago, Greydog said:

My first thought is, Is it seated on the splines properly ? Plus is it the correct wiper for the car 

Dave

Hi again Dave, 

Up until yesterday (before I replaced the wiper blade) the rear wiper has been working absolutely fine and doing a full sweep from bottom left to bottom right and then back to bottom left nice and smoothly then as soon as I e changed the blade it started making this noise even if the old (worn out) blade was put back in so I've no idea what's happened as the wiper arm is regularly lifted when washing so I've really no idea what I've done 🤷🏻‍♂️🤷🏻‍♂️

Paul 

Link to comment
Share on other sites

Can you move the wiper arm by hand ? That should tell you if the splines are loose or worn. A squirt of WD40 around the spindle perhaps to see if that works?

Dave

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Link to comment
Share on other sites

Latest Deals

BMW Official Store for genuine BMW parts & accessories

Disclaimer: As the club is an eBay Partner, The club may be compensated if you make a purchase via eBay links

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





  • Latest Topics

    1. 1

      FUEL INJECTOR FAILURE/TIME BELT

    2. 1

      FUEL INJECTOR FAILURE/TIME BELT

    3. 3

      Buying an X1.

    4. 3

      Buying an X1.

    5. 4

      Rear knocking

  • Recent Achievements

    • LRR earned a badge
      Conversation Starter
    • BobW earned a badge
      First Post
    • Clunk 84 earned a badge
      Conversation Starter
    • Neil M earned a badge
      Week One Done
    • oldnotbroken earned a badge
      First Post

×
×
  • Create New...

Forums


News


Membership