Jump to content

Caravan Towing Electrics


Recommended Posts

The other day while towing our caravan I accidentally allowed the the electric cable to trail on the ground and it was partly severed.

I have replaced the cable but the Grey wire which supplies power from the car to the fridge (ignition on) is no longer live.  I have checked all of the fuses shown to be for towing on the fuse box diagram and every single fuse on the fuse board in the trunk. All fine. I would be grateful for any advice to help locate the problem.  Could there be a relay that may have failed? In-Line fuse?

Link to comment
Share on other sites


Morning Chris

Welcome to the Forum

Hope this helps 

Its doesn't switch on the ignition live straight away though and has some pre conditions before pin goes live.

There might be a chance that it needs coding to activate the switched ignition but everything is there already from the trailer module to the 13 pin socket.


Name:  X3 trailer module.jpg Views: 268 Size:  141.0 KB
Name:  X3 ignition live requirements.jpg Views: 173 Size:  138.0 KB

Link to comment
Share on other sites

Oh that's brilliant information thank you.  It could be the trailer braking module?  I have bimmercode and bimmerlink so will look for the option.  

Do you have any advice on locating the module please?

Regards

Chris

 

 

Link to comment
Share on other sites

Morning Chris 

I believe the Trailer Braking module was only fitted for certain markets (USA) it was fitted I believe in the boot with the towing electrics control package 

Don't dismiss the battery information BMW OEM supply was Westfalia it maybe worth talking to some of their Agents

Good Luck 

Dave

Link to comment
Share on other sites

Thanks Dave, I have just sorted it.  I have found a 15amp fuse floating in a separate bank near the battery (image attached) which had blown and now I have power restored to the fridge supply.  Now I just need to sort the fridge out which has also been affected. 

Many thanks again.

Chris

Fuse.jpg

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



  • Latest Topics

    1. 1

      Blocked washers it seems

    2. 1

      Blocked washers it seems

    3. 15

      Splutters when start from cold.

    4. 15

      Splutters when start from cold.

    5. 2

      R61 JCW Mystery no code fault

  • Recent Achievements

    • jenksy0198 went up a rank
      Explorer
    • Joseph80 earned a badge
      One Month Later
    • SkipG earned a badge
      Conversation Starter
    • SkipG earned a badge
      One Month Later
    • SkipG earned a badge
      One Year In

×
×
  • Create New...

Forums


News


Membership