Jump to content

power lost then came back then lost again


Sav77
 Share

Recommended Posts

Not sure if this has been answered before.

My 525d e60 lost power few months ago.  Then it just came back on its own. Then went again last week.  Does anyone have any ideas what the problem is ???

 

Link to comment
Share on other sites


Morning Ben

Welcome to the Forum

Lost Power? Electrical or Engine ? All our answers will be guess's on so little information

If its Electrical could be a whole raft of things so if you can't DIY you need an Auto Electrician or good Garage. If it's Engine have you continued driving it with reduced power?? Again if you can't DIY you need help it could be Turbo or Turbo actuator related it could be a fuel pump issue or injector issue it could be EGR related. A full Diagnostic session is needed.

Dave

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



  • Latest Topics

    1. 0

      How to add a key for BMW CAS4 mask 5M48H1N35H via OBD

    2. 2

      Power Message

    3. 2

      Power Message

    4. 1

      E83 indicator relay location.

    5. 1

      BST cable wiring diagram e93

  • Recent Achievements

    • J 535d earned a badge
      First Post
    • J 535d earned a badge
      Conversation Starter
    • hilly10 earned a badge
      Conversation Starter
    • Caddyman earned a badge
      Conversation Starter
    • Dave H earned a badge
      Conversation Starter

×
×
  • Create New...

Forums


News


Membership