Recommended Posts

Hi everyone! I've had a couple problems with my car.  I REALLY love my car and do not want to get rid of it. 

First : sometimes when I'm driving the transmission malfunction light comes on and the car slows down to 40 mph. IIt will not drive any faster or change gears. Sometimes pulling off to the side of the road, shutting it off then turning it on again works but most of the time once I shut it off it takes 5-10 to get it go start again. The car does not start and I have to keep jugging it till the car finally starts again. Sometimes the transmission light goes away but mostly it'll stay on for about 2 days. The DBC malfunction light comes on too. 
Second: it's been a few times that feels like the car is going to shut off or no fuel for 1  or 2 seconds, but it continues to drive  a little rough. Also couple times i went over a bump and all fail lights came on ; 
Malfunction in Transmission
DBC Malfunction! 
Drive control System
Star-off assistance inactive! 
Third: lately when I start the car a ton of white smoke comes out of the exhaust. Smells like burning oil, but I'm really not sure sometimes blue. 
Please help ..
mmakabeh@gmail.com

69288355_2402297050044490_7356055238786154496_n.jpg

69849361_417858165535263_9149827632513155072_n.jpg

Share this post


Link to post
Share on other sites
 

Welcome to the Forum Micheal

When was the last time the car was serviced? When was the last time the last time the gearbox was serviced?

You really need a Garage with the ability/equipment to read the fault codes your OBC faults pictured are not accurate just an indication. Take the car to a BMW Dealer or a BMW Specialist or an Independent with at least Autologic software they will be more able to identify the issues then once you know what it is and the cost to fix you can make informed decisions.

As an example transmission could be as simple as it needing a service. Smoke could be condensation/coolant  in the exhaust or oil mist through through a clogged EGR filter or a split pipe or something internal in the engine.

You certainly wont get the cars worth if you try to sell/trade it with the Dash lit up like a Christmas tree and it not running.right.

Dave

Share this post


Link to post
Share on other sites

With the age of the car I would try to track down an independent specialist. 

The codes don't tell you much so will need interrogating. 

As an example a friend just had issues with an ageing Citroen whose dash was lit up like the proverbial, warning lights everywhere. 

The cause.........a loose oil filler cap. 

Upt'North. 

  • Like 1

Share this post


Link to post
Share on other sites

I had serviced the car thru a BMW mechanic; 

Had many failure report such as Vanos solenoid and Cam shaft Gear. Chain tensioner ... all replaced even PCV valves all 4 x replaced.

I think it is a short or grounding issue. 

Trans was serviced one year ago but similar problems showed up. 

Share this post


Link to post
Share on other sites

A bad ground isn't a bad shout, they can show up problems everywhere. 

A bad battery can also do the same. 

Upt'North. 

 

 

Share this post


Link to post
Share on other sites

Upt'North Thank you for your help.

I started having the Malfunction Transmissions failure code  last year .

the car would crank but would not start like no gas. 

After several tries it would start and run great. 

I Took my car to a Trans Shop he serviced it and programmed it.  ( I hope he told me the truth tat he did the job) 

The car ran well for many months .. 

The problems started again this year a couple months ago all fail signs I put picture of showed up. 

My friend who is a BMW mechanic read and reset the fail codes several times and concluded the failures were correct . 

Last month he replaced all Camshaft gears, Vanus solenoids chain tensioners, oil, coolant , etc,,, all needed gaskets and seals. 

BTW my car has 155K miles.

Battery was replaced 2 weeks ago.

when the car is cold in the morning it runs like brand new. 

However after driving 30 min or so or if i drive and park  the car, sometimes it would not start and  the car shows up with similar issues and failure codes. 

And puts the transmission in safety mode of 20-40 Miles. It wont change gears and wont allow Cruise control (gives the code-  Cruise Control Failure) 

Also a few days i drove over a bump and all fail lights including key and trans and DBC , etc... all fail codes showed up. But went away after driving a little.

This is my story.. 

I believe there is a board or connection issue like short or possibly grounding issue .

Best,

Michael

 

 

Share this post


Link to post
Share on other sites

I replaced the IVM and fuel pump.

The car ran perfect for 20 min.

Parked the car and it would not start.. 

After 10 tries it started with Malfunction Trans failure. 

Please help.

Here are the failures ;
If you also read from the top of my thread it might be a little more clear.

-Malfunction in Transmission
-DBC Malfunction!
-Drive control System
-Star-off assistance inactive!

Share this post


Link to post
Share on other sites

All was good after a reset .. 
I went over a pump and all failure lights showed up after (20 min driving without issues). 
I Did check the voltage  of my brand new Bosch battery .
it seemed Ok. 
I suspect the power line form the battery to the fuse boxes is the issue. Not sure yet how to work on it. 
But i believe it is a power issue. 
I have also ordered a voltage meter that plugs into my cigarette lighter that I can see the voltage regularly. 

Share this post


Link to post
Share on other sites

You should have Minimum 12.4v at the battery 14.8v with the engine running. Check the power connections at the under bonnet jump start points are tight also engine earth strap.BMW use common earth points around the car I had issues with a corroded earth point in the boot near the battery. Cleaned and refitted no issues any more so I worked my way through all the others (there are a lot) 

Share this post


Link to post
Share on other sites


When the car is cold it starts and drives perfect for 10-15 min.
after it there is a hiccup like power loss and all failure lights come on and the car shifts to lower gear. I suspect a power issue.

Malfunction in Transmission
-DBC Malfunction!
-Drive control System
-Star-off assistance inactive!

I have shown it to a BMW repair shop and they say the transmission is bad.
But the car runs and shifts perfect for 10-15 min.
Also, last time the failures showed up my car cleared the failure codes itself while I was driving. And it showed all systems is OK.
So a power or wiring issue could be the cause as you guys mentioned it.

I think you are both correct.
I called BMW of America and a couple dealers and they all tell me there is no recall on my car 2010 BMW 650i or for the wiring.
VIN - CV92800

I am sure the power wires you mentioned could be causing this.

Can anyone send me the electrical wiring diagram and fuses for my 2010 BMW 650i ??
Greatly appreciated.
best,
mmakabeh@gmail.com

Share this post


Link to post
Share on other sites

Morning Micheal

Try www.newtis.info it is a BMW Technical Information site this is the same information used by BMW dealers it should have what you need. I would get the Alternator regulator checked as if the charging is intermittent so will the fault be. Also check the battery earth points in the boot, low voltage's cause all sorts of spurious faults and Trans Fail Safe is one.

Dave

Share this post


Link to post
Share on other sites

The Alternator needs to be replaced but I sometimes get a jolt like and the car turns off now . It looks like either it loses power completely or the voltage changes drastically and the computer loses control. 
After Sometimes i have to crank the car for a few times and then it starts ok. 
But when it runs it runs perfect.
Do you think it is the Alternator/Voltage regulator or wiring issue? Power loss to the electrical ?
I still get Malfunction in Trans .. It always did that when the issues started. 
But when cold and the car is sitting over night it starts easy and  runs perfect for approx. 15 min. 
Then it acts up, it jolts like power loss and either turns off the car or the failure lights come on. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...